summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/pelican/pelican-9999.ebuild')
-rw-r--r--app-text/pelican/pelican-9999.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/app-text/pelican/pelican-9999.ebuild b/app-text/pelican/pelican-9999.ebuild
deleted file mode 100644
index ea34fe5b61b9..000000000000
--- a/app-text/pelican/pelican-9999.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1 git-r3
-
-DESCRIPTION="A tool to generate a static blog, with restructured text or markdown input files"
-HOMEPAGE="https://blog.getpelican.com/ https://pypi.org/project/pelican/"
-EGIT_REPO_URI="https://github.com/getpelican/pelican.git"
-EGIT_CHECKOUT_DIR="${WORKDIR}/${P}"
-
-LICENSE="AGPL-3"
-SLOT="0"
-IUSE="doc examples markdown"
-
-RESTRICT="test"
-RDEPEND=">=dev-python/feedgenerator-1.9[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.7[${PYTHON_USEDEP}]
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/unidecode[${PYTHON_USEDEP}]
- dev-python/blinker[${PYTHON_USEDEP}]
- >=dev-python/six-1.4[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- markdown? ( dev-python/markdown[${PYTHON_USEDEP}] )"
-DEPEND="test? ( dev-python/markdown[${PYTHON_USEDEP}] )"
-DOCS=( README.rst )
-
-distutils_enable_tests nose
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- if use examples; then
- insinto "/usr/share/doc/${PF}"
- docompress -x "/usr/share/doc/${PF}/samples"
- doins -r samples
- fi
- distutils-r1_python_install_all
-}