summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/po4a')
-rw-r--r--app-text/po4a/Manifest1
-rw-r--r--app-text/po4a/files/po4a-0.60-man.patch18
-rw-r--r--app-text/po4a/po4a-0.60.ebuild51
3 files changed, 70 insertions, 0 deletions
diff --git a/app-text/po4a/Manifest b/app-text/po4a/Manifest
index 43a5e932869f..f5e248b0e6ef 100644
--- a/app-text/po4a/Manifest
+++ b/app-text/po4a/Manifest
@@ -1,2 +1,3 @@
DIST po4a-0.57.tar.gz 3079550 BLAKE2B 54b1d3263aa0ebd90eec61d735c3422efb5f67b2d88f91a87a6893bcdb7f06131aedadeb3577d221cf75ba07f8001f6e23409375756afec8357e26e8f0f0a1c2 SHA512 7ac2e614c126b049feeb8edbafb71a875cee78fb85d8cd74f3bf5b555cc8b2d19d5e4606b732e714e937c34e178729d73edfe559de594c5ffe811b5162b27d81
+DIST po4a-0.60.tar.gz 3799018 BLAKE2B cecc260af82318fa4dfeab7ef81a29256f6531d8d97afe379d0e3291197f5b9bd0a4379697f23186de0a70ff3476cedae98bedd19bf7cddf59e9503ffbc90202 SHA512 b1e32169221d6aaf49fa0e6a42e45a858c8608a62470e5d5b769da985e4d03e09a220384400fe36f740447770331f7b8b821f00dc9ce68d3c7b00178c146c6a9
DIST po4a-v0.59.1.tar.gz 3624434 BLAKE2B 9837a7317eecd3db540bc7c23b3d26a9110f00d9c441b1bf1d61af80bae1fe0952f875425f14d66a939456f3a90e9ea74c189d94da7471c7c9a4d0b15f3875ce SHA512 904cb5817586fef19de55e76f3a33c264f9864b5c720b727a75e78a3b690e1ecd7b10603304a762d07b340320143b83b686c9918b9fe95499ceb55482950a4d4
diff --git a/app-text/po4a/files/po4a-0.60-man.patch b/app-text/po4a/files/po4a-0.60-man.patch
new file mode 100644
index 000000000000..40927dbda818
--- /dev/null
+++ b/app-text/po4a/files/po4a-0.60-man.patch
@@ -0,0 +1,18 @@
+--- a/Po4aBuilder.pm
++++ b/Po4aBuilder.pm
+@@ -232,7 +232,6 @@
+ }
+ $parser->parse_from_file ($file, $out);
+
+- system("gzip -9 -f $out") and die;
+ unlink "$file" || die;
+ }
+
+@@ -250,7 +249,6 @@
+ print "Convert $outdir/$outfile.$section (online docbook.xsl file). ";
+ system("xsltproc -o $outdir/$outfile.$section --nonet http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl $file") and die;
+ }
+- system ("gzip -9 -f $outdir/$outfile.$section") and die;
+ }
+ unlink "$file" || die;
+ }
diff --git a/app-text/po4a/po4a-0.60.ebuild b/app-text/po4a/po4a-0.60.ebuild
new file mode 100644
index 000000000000..8807618f22d5
--- /dev/null
+++ b/app-text/po4a/po4a-0.60.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PLOCALES="af ar ca cs da de eo es et eu fr hr hu id it ja kn ko nb nl pl pt pt_BR ru sl sr_Cyrl sv uk vi zh_CN zh_HK"
+
+inherit l10n perl-module
+
+DESCRIPTION="Tools to ease the translation of documentation"
+HOMEPAGE="https://po4a.org/"
+SRC_URI="https://github.com/mquinson/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-text/opensp
+ dev-libs/libxslt
+ dev-perl/Locale-gettext
+ dev-perl/SGMLSpm
+ dev-perl/TermReadKey
+ dev-perl/Text-WrapI18N
+ dev-perl/Unicode-LineBreak
+ dev-perl/YAML-Tiny
+ sys-devel/gettext"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/docbook-xsl-stylesheets
+ dev-perl/Module-Build
+ test? (
+ app-text/docbook-sgml-dtd:4.1
+ dev-perl/Test-Pod
+ virtual/latex-base
+ )"
+
+PATCHES=( "${FILESDIR}"/${P}-man.patch )
+
+DIST_TEST="do"
+
+src_prepare() {
+ l10n_find_plocales_changes "${S}/po/bin" '' '.po'
+
+ rm_locale() {
+ PERL_RM_FILES+=( po/{bin,pod}/${1}.po )
+ }
+ l10n_for_each_disabled_locale_do rm_locale
+
+ perl-module_src_prepare
+}