summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/podofo/podofo-0.9.6_pre20170508-r1.ebuild')
-rw-r--r--app-text/podofo/podofo-0.9.6_pre20170508-r1.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/app-text/podofo/podofo-0.9.6_pre20170508-r1.ebuild b/app-text/podofo/podofo-0.9.6_pre20170508-r1.ebuild
index 9ac790385034..5c1264949294 100644
--- a/app-text/podofo/podofo-0.9.6_pre20170508-r1.ebuild
+++ b/app-text/podofo/podofo-0.9.6_pre20170508-r1.ebuild
@@ -38,6 +38,10 @@ src_prepare() {
# equal to ${PV}.
sed -e 's|${PODOFO_VERSION_PATCH}|\0_'${PV##*_}'|' -i CMakeLists.txt || die
+ # bug 620934 - Disable linking with cppunit when possible, since it
+ # triggers errors with some older compilers.
+ use test || sed -e 's:^FIND_PACKAGE(CppUnit):#\0:' -i CMakeLists.txt || die
+
# bug 556962
sed -i -e 's|Decrypt( pEncryptedBuffer, nOutputLen, pDecryptedBuffer, m_lLen );|Decrypt( pEncryptedBuffer, (pdf_long)nOutputLen, pDecryptedBuffer, (pdf_long\&)m_lLen );|' \
test/unit/EncryptTest.cpp || die