summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/qpdfview/qpdfview-0.4.17_beta1.ebuild')
-rw-r--r--app-text/qpdfview/qpdfview-0.4.17_beta1.ebuild88
1 files changed, 0 insertions, 88 deletions
diff --git a/app-text/qpdfview/qpdfview-0.4.17_beta1.ebuild b/app-text/qpdfview/qpdfview-0.4.17_beta1.ebuild
deleted file mode 100644
index 0002d29b3a05..000000000000
--- a/app-text/qpdfview/qpdfview-0.4.17_beta1.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PLOCALES="ast az be bg bs ca cs da de el en_GB eo es eu fi fr gl he hr hu id it kk ko ky lt ms my pl pt pt_BR ro ru sk sv th tr ug uk vi zh_CN"
-
-inherit l10n qmake-utils
-
-DESCRIPTION="A tabbed document viewer"
-HOMEPAGE="https://launchpad.net/qpdfview"
-SRC_URI="https://launchpad.net/${PN}/trunk/${PV/_/}/+download/${P/_/}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
-IUSE="cups +dbus djvu fitz +pdf postscript +sqlite +svg synctex"
-
-REQUIRED_USE="?? ( fitz pdf )"
-
-RDEPEND="
- dev-qt/qtconcurrent:5
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtprintsupport:5
- dev-qt/qtwidgets:5
- cups? ( net-print/cups )
- dbus? ( dev-qt/qtdbus:5 )
- djvu? ( app-text/djvu )
- fitz? ( >=app-text/mupdf-1.7:= )
- pdf? (
- >=app-text/poppler-0.35[qt5]
- dev-qt/qtxml:5
- )
- postscript? ( app-text/libspectre )
- sqlite? ( dev-qt/qtsql:5[sqlite] )
- svg? ( dev-qt/qtsvg:5 )
- !svg? ( virtual/freedesktop-icon-theme )
- synctex? ( app-text/texlive-core )"
-DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5
- virtual/pkgconfig"
-
-DOCS=( CHANGES CONTRIBUTORS README TODO )
-
-S="${WORKDIR}/${P/_/}"
-
-src_prepare() {
- local mylrelease="$(qt5_get_bindir)"/lrelease
-
- prepare_locale() {
- "${mylrelease}" "translations/${PN}_${1}.ts" || die "preparing ${1} locale failed"
- }
-
- rm_help() {
- rm -f "help/help_${1}.html" || die "removing ${1} help file failed"
- }
-
- l10n_find_plocales_changes translations ${PN}_ .ts
- l10n_for_each_locale_do prepare_locale
- l10n_for_each_disabled_locale_do rm_help
-
- # adapt for prefix
- sed -i -e "s:/usr:${EPREFIX}/usr:g" qpdfview.pri || die
-
- default
-}
-
-src_configure() {
- local myconfig=() i=
- for i in cups dbus djvu pdf svg synctex; do
- use ${i} || myconfig+=(without_${i})
- done
- use fitz && myconfig+=(with_fitz)
- use postscript || myconfig+=(without_ps)
- use sqlite || myconfig+=(without_sql)
-
- local myqmakeargs=(
- qpdfview.pro
- CONFIG+="${myconfig[@]}"
- PLUGIN_INSTALL_PATH="${EPREFIX}/usr/$(get_libdir)/${PN}"
- )
- eqmake5 "${myqmakeargs[@]}"
-}
-
-src_install() {
- emake INSTALL_ROOT="${D}" install
- einstalldocs
-}