summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/spellutils')
-rw-r--r--app-text/spellutils/Manifest1
-rw-r--r--app-text/spellutils/files/spellutils-0.7-nls.patch13
-rw-r--r--app-text/spellutils/metadata.xml7
-rw-r--r--app-text/spellutils/spellutils-0.7.ebuild36
4 files changed, 57 insertions, 0 deletions
diff --git a/app-text/spellutils/Manifest b/app-text/spellutils/Manifest
new file mode 100644
index 000000000000..822f921c8900
--- /dev/null
+++ b/app-text/spellutils/Manifest
@@ -0,0 +1 @@
+DIST spellutils-0.7.tar.bz2 110421 SHA256 0d5723321b6d60f31a93a43708904b2fddfcff3ec2fdd30e13214c64dd28e875 SHA512 030b06038c587e668fcbef95afc64e28db48a25f2b247b829155c1a5b66d3b3012650cb4c13e5de41a70a1665b05fbfb44a4cd0b1295868e611a21d855f02f9e WHIRLPOOL eae95485f51ef7bede2076c60a7b2aa3f36b57723bb30aadc8fd863aded939f0529e18e656cc18cdb614945657ccecbb4ebf5580aa598974edaf2485ac71a709
diff --git a/app-text/spellutils/files/spellutils-0.7-nls.patch b/app-text/spellutils/files/spellutils-0.7-nls.patch
new file mode 100644
index 000000000000..ff36f67a9823
--- /dev/null
+++ b/app-text/spellutils/files/spellutils-0.7-nls.patch
@@ -0,0 +1,13 @@
+--- po/Makefile.in.in.orig 2000-04-16 12:04:50.000000000 +0200
++++ po/Makefile.in.in 2013-07-24 04:14:20.698869858 +0200
+@@ -119,8 +119,8 @@
+ for cat in $$catalogs; do \
+ cat=`basename $$cat`; \
+ case "$$cat" in \
+- *.gmo) destdir=$(gnulocaledir);; \
+- *) destdir=$(localedir);; \
++ *.gmo) destdir=$(DESTDIR)/$(gnulocaledir);; \
++ *) destdir=$(DESTDIR)/$(localedir);; \
+ esac; \
+ lang=`echo $$cat | sed 's/\$(CATOBJEXT)$$//'`; \
+ dir=$$destdir/$$lang/LC_MESSAGES; \
diff --git a/app-text/spellutils/metadata.xml b/app-text/spellutils/metadata.xml
new file mode 100644
index 000000000000..d9cd2cad66c2
--- /dev/null
+++ b/app-text/spellutils/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/app-text/spellutils/spellutils-0.7.ebuild b/app-text/spellutils/spellutils-0.7.ebuild
new file mode 100644
index 000000000000..7909181c3805
--- /dev/null
+++ b/app-text/spellutils/spellutils-0.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="spellutils includes 'newsbody' (useful for spellchecking in mails, etc.)"
+HOMEPAGE="http://home.worldonline.dk/byrial/spellutils/"
+SRC_URI="http://home.worldonline.dk/byrial/spellutils/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc ~sparc alpha ~mips ~hppa amd64"
+IUSE="nls"
+
+DEPEND="
+ nls? ( sys-devel/gettext )
+"
+DEPEND="
+ nls? ( virtual/libintl )
+"
+
+DOCS=( NEWS README )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-nls.patch
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}