summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/xournal/xournal-9999.ebuild')
-rw-r--r--app-text/xournal/xournal-9999.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/app-text/xournal/xournal-9999.ebuild b/app-text/xournal/xournal-9999.ebuild
index 422842c0e82f..50477f8a4537 100644
--- a/app-text/xournal/xournal-9999.ebuild
+++ b/app-text/xournal/xournal-9999.ebuild
@@ -1,9 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-GCONF_DEBUG=no
+EAPI=6
[[ ${PV} == *9999 ]] && GNOME2_EAUTORECONF=yes
@@ -23,7 +21,7 @@ HOMEPAGE="http://xournal.sourceforge.net/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="+pdf"
+IUSE="+pdf vanilla"
COMMONDEPEND="
app-text/poppler[cairo]
@@ -45,10 +43,17 @@ DEPEND="${COMMONDEPEND}
virtual/pkgconfig
"
+src_prepare() {
+ default_src_prepare
+ if ! use vanilla; then
+ eapply "${FILESDIR}"/xournal-0.4.8-aspectratio.patch
+ fi
+}
+
src_install() {
emake DESTDIR="${D}" install
emake DESTDIR="${D}" desktop-install
dodoc ChangeLog AUTHORS README
- dohtml -r html-doc/*
+ dodoc -r html-doc/*
}