summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/master-pdf-editor/Manifest1
-rw-r--r--app-text/master-pdf-editor/master-pdf-editor-5.0.36.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-text/master-pdf-editor/Manifest b/app-text/master-pdf-editor/Manifest
index e7193527c16e..f387cc6bd230 100644
--- a/app-text/master-pdf-editor/Manifest
+++ b/app-text/master-pdf-editor/Manifest
@@ -1 +1,2 @@
DIST master-pdf-editor-4.3.82_qt5.amd64.tar.gz 14934502 BLAKE2B f93c756f9270b2857af02047c6ebd242d35ddaf23b70118d440c21cc7a0718937aa9945bb24adad6544e984f9390e9f49bfce5298bb8bc54f3c705372aff0fd4 SHA512 9bc6b056bdc8ce349dbab139f64c90948f3e0498918f07df6249fee2fad98a35b133aa7913e375366d062e134878feed0fadd097ab1d5504e97884ffa2c37b24
+DIST master-pdf-editor-5.0.36_qt5.amd64.tar.gz 16021838 BLAKE2B d46b9f6205e2832535060584a8841e3fa35d3b59c99a7fc2bcca5f913771633eed0d987a94141ef186b2077b65c781509b5f9938a033a5a856a9b0ad914bd5fc SHA512 31bae232d4629e10b29a4c7273ef7635bb7ec7cce9dc837355fc0d9aacc98943ec009eeac7b445f022831da8a2c400a7ce2b1de82b4e780d625ff49120e2a964
diff --git a/app-text/master-pdf-editor/master-pdf-editor-5.0.36.ebuild b/app-text/master-pdf-editor/master-pdf-editor-5.0.36.ebuild
new file mode 100644
index 000000000000..6ef28a8e6ba9
--- /dev/null
+++ b/app-text/master-pdf-editor/master-pdf-editor-5.0.36.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit xdg-utils desktop
+
+DESCRIPTION="Master PDF Editor is a complete solution for viewing and editing PDF files"
+HOMEPAGE="https://code-industry.net/free-pdf-editor/"
+SRC_URI="http://code-industry.net/public/${P}_qt5.amd64.tar.gz"
+
+LICENSE="master-pdf-editor"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror"
+
+COMMON_DEPEND="
+ >=media-gfx/sane-backends-1.0
+ >=dev-qt/qtsvg-5.4.1:5
+ >=dev-qt/qtnetwork-5.4.1:5
+ >=dev-qt/qtgui-5.4.1:5
+ >=dev-qt/qtprintsupport-5.4.1:5
+"
+
+RDEPEND="${COMMON_DEPEND}"
+
+QA_PREBUILT="/opt/${PN}/masterpdfeditor5"
+
+S="${WORKDIR}/${PN}-${PV%%.*}"
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r fonts lang stamps templates masterpdfeditor5.png
+
+ exeinto /opt/${PN}
+ doexe masterpdfeditor5
+
+ dosym ../${PN}/masterpdfeditor5 /opt/bin/masterpdfeditor5
+ make_desktop_entry "masterpdfeditor5 %f" \
+ "Master PDF Editor ${PV}" /opt/${PN}/masterpdfeditor5.png \
+ "Office;Graphics;Viewer" \
+ "MimeType=application/pdf;application/x-bzpdf;application/x-gzpdf;\nTerminal=false"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}