summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/html401/html401-19991224-r3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-text/html401/html401-19991224-r3.ebuild b/app-text/html401/html401-19991224-r3.ebuild
new file mode 100644
index 000000000000..c6742475dd1a
--- /dev/null
+++ b/app-text/html401/html401-19991224-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit sgml-catalog eutils
+
+DESCRIPTION="DTDs for the HyperText Markup Language 4.01"
+HOMEPAGE="http://www.w3.org/TR/html401/"
+SRC_URI="http://www.w3.org/TR/html401/html40.tgz"
+
+LICENSE="W3C"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~s390 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+DEPEND="app-text/sgml-common"
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_prepare() {
+ sgml-catalog_cat_include "/etc/sgml/${PN}.cat" \
+ "/usr/share/sgml/${PN}/HTML4.cat"
+ epatch "${FILESDIR}"/${PN}-decl.diff
+}
+
+src_install() {
+ insinto /usr/share/sgml/${PN}
+ doins HTML4.cat HTML4.decl *.dtd *.ent
+ insinto /usr/share/doc/${PF}/html
+ doins -r *.html $(ls -p | fgrep "/" | sed "s#/##")
+}