summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/NaturalDocs/Manifest1
-rw-r--r--app-text/NaturalDocs/NaturalDocs-1.52-r2.ebuild51
-rw-r--r--app-text/NaturalDocs/metadata.xml19
3 files changed, 71 insertions, 0 deletions
diff --git a/app-text/NaturalDocs/Manifest b/app-text/NaturalDocs/Manifest
new file mode 100644
index 000000000000..15d3dd0bf7d3
--- /dev/null
+++ b/app-text/NaturalDocs/Manifest
@@ -0,0 +1 @@
+DIST NaturalDocs-1.52.zip 460793 BLAKE2B d4ecd8bb8dd3fa92a8d9366077c65ddd70e9c4944519cb453e0752e2df0ed22d7fe23aa1edb1e63ffea16b0d0f56794d50a6a0520b2b91f0193a83326ac34c5b SHA512 45d79dd2bf55a8cb7356eb5321a8c99cbab9d69a4d9a97033737090df2bfd86ee7a058a03016646c7fd6f20daf6523b2d77cd2248a7503a6c5c22684f08431c1
diff --git a/app-text/NaturalDocs/NaturalDocs-1.52-r2.ebuild b/app-text/NaturalDocs/NaturalDocs-1.52-r2.ebuild
new file mode 100644
index 000000000000..3c51d42cd125
--- /dev/null
+++ b/app-text/NaturalDocs/NaturalDocs-1.52-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit perl-module
+
+DESCRIPTION="Extensible, multi-language source code documentation generator"
+HOMEPAGE="http://www.naturaldocs.org/"
+SRC_URI="mirror://sourceforge/naturaldocs/${P}.zip"
+S="${WORKDIR}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ppc ppc64 ~riscv sparc x86"
+
+BDEPEND="app-arch/unzip"
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r Styles Info JavaScript
+
+ insinto /etc/${PN}
+ doins -r Config/.
+ dosym ../../../etc/${PN} /usr/share/${PN}/Config
+
+ perl_set_version
+ insinto ${VENDOR_LIB}
+ doins -r Modules/NaturalDocs
+ dodir /usr/share/${PN}/Modules
+ dosym ../../../..${VENDOR_LIB}/NaturalDocs /usr/share/${PN}/Modules/NaturalDocs
+
+ exeinto /usr/share/${PN}
+ doexe ${PN}
+
+ # Symlink the Perl script into /usr/bin
+ dodir /usr/bin
+ dosym ../share/${PN}/${PN} /usr/bin/${PN}
+
+ # Documentation
+ dodoc -r Help/.
+ dosym ../doc/${PF}/html /usr/share/${PN}/Help
+}
+
+pkg_preinst() {
+ if [[ -e /usr/share/${PN}/Config && ! -L /usr/share/${PN}/Config ]] ; then
+ mkdir -p /etc/${PN}
+ mv /usr/share/${PN}/Config/* /etc/${PN}/
+ rm -rf /usr/share/${PN}/Config
+ fi
+}
diff --git a/app-text/NaturalDocs/metadata.xml b/app-text/NaturalDocs/metadata.xml
new file mode 100644
index 000000000000..54582d69c8da
--- /dev/null
+++ b/app-text/NaturalDocs/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ Natural Docs is an open-source, extensible, multi-language
+ documentation generator. It extracts specially formatted comments
+ from source code and builds HTML documentation from it. The syntax
+ is transparent so that the comments in the source code read just as
+ easily as the generated documentation. It also focuses on automation
+ and high-quality generated output.
+ </longdescription>
+ <maintainer type="person">
+ <email>titanofold@gentoo.org</email>
+ <name>Aaron W. Swenson</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">naturaldocs</remote-id>
+ </upstream>
+</pkgmetadata>