summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/fugitive/fugitive-3.4.ebuild')
-rw-r--r--app-vim/fugitive/fugitive-3.4.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-vim/fugitive/fugitive-3.4.ebuild b/app-vim/fugitive/fugitive-3.4.ebuild
new file mode 100644
index 000000000000..468c05838b33
--- /dev/null
+++ b/app-vim/fugitive/fugitive-3.4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit vim-plugin
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tpope/vim-fugitive.git"
+else
+ SRC_URI="https://github.com/tpope/vim-fugitive/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos"
+ S="${WORKDIR}/vim-${P}"
+fi
+
+DESCRIPTION="vim plugin: a git wrapper for vim"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=2975 https://github.com/tpope/vim-fugitive/"
+LICENSE="vim"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-vcs/git"