summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/vimtex/vimtex-1.5.ebuild')
-rw-r--r--app-vim/vimtex/vimtex-1.5.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-vim/vimtex/vimtex-1.5.ebuild b/app-vim/vimtex/vimtex-1.5.ebuild
new file mode 100644
index 000000000000..23e077e8f05f
--- /dev/null
+++ b/app-vim/vimtex/vimtex-1.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: a modern vim plugin for editing LaTeX files"
+HOMEPAGE="https://github.com/lervag/vimtex"
+SRC_URI="https://github.com/lervag/vimtex/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+LICENSE="MIT"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+RDEPEND="
+ !app-vim/vim-latex
+ !app-vim/automatictexplugin"
+
+src_prepare() {
+ default
+
+ # remove unwanted files
+ rm -r *.md media test || die
+}