summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-xemacs/ebuild-mode/ebuild-mode-1.36.ebuild')
-rw-r--r--app-xemacs/ebuild-mode/ebuild-mode-1.36.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-xemacs/ebuild-mode/ebuild-mode-1.36.ebuild b/app-xemacs/ebuild-mode/ebuild-mode-1.36.ebuild
new file mode 100644
index 000000000000..d1c1ca9bde66
--- /dev/null
+++ b/app-xemacs/ebuild-mode/ebuild-mode-1.36.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit xemacs-elisp
+
+DESCRIPTION="Emacs modes for editing ebuilds and other Gentoo specific files"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
+SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=app-editors/xemacs-21.4.20-r5
+ app-xemacs/sh-script"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ ${XEMACS_BATCH_CLEAN} -eval "(add-to-list 'load-path \".\")" \
+ -f batch-byte-compile ebuild-mode.el gentoo-newsitem-mode.el || die
+ xemacs-elisp-make-autoload-file *.el || die
+}