summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ada/xmlada/xmlada-2019-r1.ebuild')
-rw-r--r--dev-ada/xmlada/xmlada-2019-r1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-ada/xmlada/xmlada-2019-r1.ebuild b/dev-ada/xmlada/xmlada-2019-r1.ebuild
index 794b5c7d879d..a08b9acda13c 100644
--- a/dev-ada/xmlada/xmlada-2019-r1.ebuild
+++ b/dev-ada/xmlada/xmlada-2019-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -28,11 +28,11 @@ S="${WORKDIR}"/${MYP}-src
PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
-src_configure () {
+src_configure() {
econf --prefix="${D}"/usr
}
-src_compile () {
+src_compile() {
build () {
gprbuild -j$(makeopts_jobs) -m -p -v -XLIBRARY_TYPE=$1 \
-XBUILD=Production -XPROCESSORS=$(makeopts_jobs) xmlada.gpr \
@@ -55,7 +55,7 @@ src_test() {
grep -q DIFF xmlada.testLog && die
}
-src_install () {
+src_install() {
build () {
gprinstall -XLIBRARY_TYPE=$1 -f -p -XBUILD=Production \
-XPROCESSORS=$(makeopts_jobs) --prefix="${D}"/usr \