summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ada')
-rw-r--r--dev-ada/xmlada/files/xmlada-2016-gentoo.patch9
-rw-r--r--dev-ada/xmlada/xmlada-2016.ebuild4
-rw-r--r--dev-ada/xmlada/xmlada-9999.ebuild49
3 files changed, 53 insertions, 9 deletions
diff --git a/dev-ada/xmlada/files/xmlada-2016-gentoo.patch b/dev-ada/xmlada/files/xmlada-2016-gentoo.patch
index e167c1df1452..def06255cf5a 100644
--- a/dev-ada/xmlada/files/xmlada-2016-gentoo.patch
+++ b/dev-ada/xmlada/files/xmlada-2016-gentoo.patch
@@ -1,14 +1,5 @@
--- xmlada-2016-src/Makefile.in.old 2016-12-04 21:58:57.251338692 +0100
+++ xmlada-2016-src/Makefile.in 2016-12-04 21:59:31.332755615 +0100
-@@ -7,7 +7,7 @@
- PACKAGE_TARNAME=@PACKAGE_TARNAME@
- VERSION=@PACKAGE_VERSION@
- BUILDS_SHARED=@GNAT_BUILDS_SHARED@
--prefix=@prefix@
-+prefix=$(DESTDIR)@prefix@
-
- # Set a default value (ignored if set in the environment)
- PROCESSORS?=0
@@ -49,13 +49,13 @@
endif
diff --git a/dev-ada/xmlada/xmlada-2016.ebuild b/dev-ada/xmlada/xmlada-2016.ebuild
index a6cef15df53f..793f92040c8b 100644
--- a/dev-ada/xmlada/xmlada-2016.ebuild
+++ b/dev-ada/xmlada/xmlada-2016.ebuild
@@ -25,6 +25,10 @@ S="${WORKDIR}"/${MYP}-src
PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+src_configure () {
+ econf --prefix="${D}"/usr
+}
+
src_compile () {
for kind in shared static static-pic; do
if use ${kind}; then
diff --git a/dev-ada/xmlada/xmlada-9999.ebuild b/dev-ada/xmlada/xmlada-9999.ebuild
new file mode 100644
index 000000000000..5c1f5b3d25b0
--- /dev/null
+++ b/dev-ada/xmlada/xmlada-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit git-r3 multiprocessing
+
+MYP=${PN}-gpl-${PV}
+
+DESCRIPTION="Set of modules that provide a simple manipulation of XML streams"
+HOMEPAGE="http://libre.adacore.com/"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/AdaCore/xmlada.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="+shared static static-pic"
+REQUIRED_USE="|| ( shared static static-pic )"
+
+RDEPEND="dev-lang/gnat-gpl"
+DEPEND="${RDEPEND}
+ dev-ada/gprbuild"
+
+PATCHES=( "${FILESDIR}"/${PN}-2016-gentoo.patch )
+
+src_configure () {
+ econf --prefix="${D}"/usr
+}
+
+src_compile () {
+ for kind in shared static static-pic; do
+ if use ${kind}; then
+ emake PROCESSORS=$(makeopts_jobs) ${kind}
+ fi
+ done
+}
+
+src_install () {
+ for kind in shared static static-pic; do
+ if use ${kind}; then
+ emake PROCESSORS=$(makeopts_jobs) DESTDIR="${D}" install-${kind}
+ fi
+ done
+ einstalldocs
+ dodoc features-* known-problems-* xmlada-roadmap.txt
+ rm "${D}"/usr/share/doc/${PN}/.buildinfo || die
+ mv "${D}"/usr/share/doc/${PN} "${D}"/usr/share/doc/${PF}/html || die
+}