summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/ETL/ETL-0.04.15.ebuild')
-rw-r--r--dev-cpp/ETL/ETL-0.04.15.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-cpp/ETL/ETL-0.04.15.ebuild b/dev-cpp/ETL/ETL-0.04.15.ebuild
new file mode 100644
index 000000000000..e377c0ede9ee
--- /dev/null
+++ b/dev-cpp/ETL/ETL-0.04.15.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools
+
+DESCRIPTION="ETL is a multi-platform class and template library"
+HOMEPAGE="http://synfig.org"
+SRC_URI="mirror://sourceforge/synfig/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e 's/CXXFLAGS="`echo $CXXFLAGS | sed s:-g::` $debug_flags"//' \
+ -e 's/CFLAGS="`echo $CFLAGS | sed s:-g::` $debug_flags"//' \
+ m4/subs.m4
+
+ eautoreconf
+}