summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/cairomm/cairomm-1.12.0-r1.ebuild')
-rw-r--r--dev-cpp/cairomm/cairomm-1.12.0-r1.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-cpp/cairomm/cairomm-1.12.0-r1.ebuild b/dev-cpp/cairomm/cairomm-1.12.0-r1.ebuild
deleted file mode 100644
index 98407388284e..000000000000
--- a/dev-cpp/cairomm/cairomm-1.12.0-r1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-GCONF_DEBUG="no"
-
-inherit gnome2 multilib-minimal
-
-DESCRIPTION="C++ bindings for the Cairo vector graphics library"
-HOMEPAGE="https://cairographics.org/cairomm/"
-
-LICENSE="LGPL-2+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
-IUSE="aqua doc +svg X"
-
-RDEPEND="
- >=x11-libs/cairo-1.12.10[aqua=,svg=,X=,${MULTILIB_USEDEP}]
- >=dev-libs/libsigc++-2.5.1:2[${MULTILIB_USEDEP}]
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? (
- app-doc/doxygen
- dev-libs/libxslt
- media-gfx/graphviz )
-"
-
-src_prepare() {
- # don't waste time building examples because they are marked as "noinst"
- sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' Makefile.in || die
-
- # don't waste time building tests
- # they require the boost Unit Testing framework, that's not in base boost
- sed -i 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' Makefile.in || die
-
- gnome2_src_prepare
-}
-
-multilib_src_configure() {
- ECONF_SOURCE="${S}" gnome2_src_configure \
- --disable-tests \
- $(multilib_native_use_enable doc documentation)
-}
-
-multilib_src_install() {
- gnome2_src_install
-}