summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/catch/catch-1.9999.ebuild')
-rw-r--r--dev-cpp/catch/catch-1.9999.ebuild17
1 files changed, 6 insertions, 11 deletions
diff --git a/dev-cpp/catch/catch-1.9999.ebuild b/dev-cpp/catch/catch-1.9999.ebuild
index b6b3d982a71b..4cad4e13c4b7 100644
--- a/dev-cpp/catch/catch-1.9999.ebuild
+++ b/dev-cpp/catch/catch-1.9999.ebuild
@@ -14,21 +14,16 @@ SRC_URI=""
LICENSE="Boost-1.0"
SLOT="0"
KEYWORDS=""
-IUSE=""
+IUSE="test"
-# CMake is only used to build & run tests, so override phases
-src_configure() { :; }
-src_compile() { :; }
-
-src_test() {
+src_configure() {
+ local mycmakeargs=(
+ -DNO_SELFTEST=$(usex !test)
+ )
cmake-utils_src_configure
- cmake-utils_src_compile
- cmake-utils_src_test
}
src_install() {
- # same location as used in fedora
- insinto /usr/include/catch
- doins -r include/.
+ cmake-utils_src_install
dodoc -r docs/.
}