summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/folly/folly-2022.07.04.00.ebuild')
-rw-r--r--dev-cpp/folly/folly-2022.07.04.00.ebuild92
1 files changed, 0 insertions, 92 deletions
diff --git a/dev-cpp/folly/folly-2022.07.04.00.ebuild b/dev-cpp/folly/folly-2022.07.04.00.ebuild
deleted file mode 100644
index c22332816b46..000000000000
--- a/dev-cpp/folly/folly-2022.07.04.00.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake toolchain-funcs
-
-DESCRIPTION="An open-source C++ library developed and used at Facebook"
-HOMEPAGE="https://github.com/facebook/folly"
-SRC_URI="https://github.com/facebook/folly/releases/download/v${PV}/${PN}-v${PV}.tar.gz"
-S="${WORKDIR}"
-
-LICENSE="Apache-2.0"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="llvm-libunwind test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="app-arch/bzip2
- app-arch/lz4:=
- app-arch/snappy:=
- app-arch/xz-utils
- app-arch/zstd:=
- dev-cpp/gflags:=
- dev-cpp/glog:=[gflags]
- dev-libs/boost:=[context]
- dev-libs/double-conversion:=
- dev-libs/libaio
- dev-libs/libevent:=
- dev-libs/libfmt:=
- dev-libs/libsodium:=
- dev-libs/openssl:=
- sys-libs/liburing:=
- sys-libs/zlib
- llvm-libunwind? ( sys-libs/llvm-libunwind:= )
- !llvm-libunwind? ( sys-libs/libunwind:= )"
-# libiberty is linked statically
-DEPEND="${RDEPEND}
- sys-libs/binutils-libs"
-BDEPEND="test? ( sys-devel/clang )"
-
-PATCHES=(
- "${FILESDIR}/${PN}"-2022.07.04.00-musl-fix.patch
-)
-
-pkg_setup() {
- [[ ${BUILD_TYPE} == "binary" ]] && return
-
- if use test && ! tc-is-clang ; then
- # Always build w/ Clang for now to avoid gcc ICE
- # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=106230
- #if [[ $(gcc-major-version) -eq 12 ]] ; then
- # return
- #fi
-
- ## Only older GCC 11 is broken
- #if [[ $(gcc-major-version) -eq 11 && $(gcc-minor-version) -ge 3 && $(gcc-micro-version) -ge 1 ]] ; then
- # return
- #fi
-
- ewarn "Forcing build with Clang due to GCC bug (because tests are enabled)"
- #ewarn "(https://gcc.gnu.org/bugzilla/show_bug.cgi?id=104008)"
-
- export CC=${CHOST}-clang
- export CXX=${CHOST}-clang++
- fi
-}
-
-src_configure() {
- # TODO: liburing could in theory be optional but fails to link
-
- local mycmakeargs=(
- -DLIB_INSTALL_DIR="$(get_libdir)"
-
- -DBUILD_TESTS=$(usex test)
- )
-
- cmake_src_configure
-}
-
-src_test() {
- local myctestargs=(
- # - timeseries_histogram_test.TimeseriesHistogram.Percentile|HHWheelTimerTest
- # Long-standing known test failure
- # TODO: report upstream
- # - HHWheelTimerTest.HHWheelTimerTest.CancelTimeout
- # Timeouts are fragile
- -E "(timeseries_histogram_test.TimeseriesHistogram.Percentile|HHWheelTimerTest.HHWheelTimerTest.CancelTimeout)"
- )
-
- cmake_src_test
-}