summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/gmock/gmock-1.4.0.ebuild')
-rw-r--r--dev-cpp/gmock/gmock-1.4.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-cpp/gmock/gmock-1.4.0.ebuild b/dev-cpp/gmock/gmock-1.4.0.ebuild
new file mode 100644
index 000000000000..f9a10aca3390
--- /dev/null
+++ b/dev-cpp/gmock/gmock-1.4.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit libtool eutils
+
+DESCRIPTION="Google's C++ mocking framework"
+HOMEPAGE="http://code.google.com/p/googlemock/"
+SRC_URI="http://googlemock.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="static-libs"
+
+RDEPEND=">=dev-cpp/gtest-${PV}"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ default
+ # make sure we always use the system one
+ rm -r "${S}"/gtest/Makefile* || die
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc-4.7.patch
+ epatch "${FILESDIR}"/${P}-more-gcc-4.7.patch
+ elibtoolize
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || find "${ED}"/usr -name '*.la' -delete
+}