summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/gulrak-filesystem/gulrak-filesystem-1.5.12.ebuild')
-rw-r--r--dev-cpp/gulrak-filesystem/gulrak-filesystem-1.5.12.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-cpp/gulrak-filesystem/gulrak-filesystem-1.5.12.ebuild b/dev-cpp/gulrak-filesystem/gulrak-filesystem-1.5.12.ebuild
index e8918cc422cf..e35c0185bc92 100644
--- a/dev-cpp/gulrak-filesystem/gulrak-filesystem-1.5.12.ebuild
+++ b/dev-cpp/gulrak-filesystem/gulrak-filesystem-1.5.12.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -17,6 +17,11 @@ RESTRICT="!test? ( test )"
S="${WORKDIR}/${P#*-}"
+src_prepare() {
+ cmake_src_prepare
+ sed -i "s:-Werror::g" cmake/GhcHelper.cmake test/CMakeLists.txt || die
+}
+
src_configure() {
local mycmakeargs=(
-DGHC_FILESYSTEM_BUILD_EXAMPLES=OFF