summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/jwt-cpp')
-rw-r--r--dev-cpp/jwt-cpp/files/jwt-cpp-0.6.0-gcc13.patch14
-rw-r--r--dev-cpp/jwt-cpp/jwt-cpp-0.6.0.ebuild3
2 files changed, 17 insertions, 0 deletions
diff --git a/dev-cpp/jwt-cpp/files/jwt-cpp-0.6.0-gcc13.patch b/dev-cpp/jwt-cpp/files/jwt-cpp-0.6.0-gcc13.patch
new file mode 100644
index 000000000000..3fef24536a86
--- /dev/null
+++ b/dev-cpp/jwt-cpp/files/jwt-cpp-0.6.0-gcc13.patch
@@ -0,0 +1,14 @@
+From: Hannu Lounento <hannu.lounento@vaisala.com>
+Bug: https://github.com/Thalhammer/jwt-cpp/pull/287
+
+Fix build with GCC 13.
+
+--- a/include/jwt-cpp/base.h
++++ b/include/jwt-cpp/base.h
+@@ -3,6 +3,7 @@
+
+ #include <array>
++#include <cstdint>
+ #include <stdexcept>
+ #include <string>
+
diff --git a/dev-cpp/jwt-cpp/jwt-cpp-0.6.0.ebuild b/dev-cpp/jwt-cpp/jwt-cpp-0.6.0.ebuild
index c7f9802a739a..8d2bc1f2fe86 100644
--- a/dev-cpp/jwt-cpp/jwt-cpp-0.6.0.ebuild
+++ b/dev-cpp/jwt-cpp/jwt-cpp-0.6.0.ebuild
@@ -34,6 +34,9 @@ RESTRICT="
!picojson? ( test )
!test? ( test )
"
+PATCHES=(
+ "${FILESDIR}"/"${PN}"-0.6.0-gcc13.patch
+)
DOCS=( README.md docs/{faqs,ssl,traits}.md )
src_prepare() {