summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/mvfst/mvfst-2024.11.04.00-r1.ebuild')
-rw-r--r--dev-cpp/mvfst/mvfst-2024.11.04.00-r1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-cpp/mvfst/mvfst-2024.11.04.00-r1.ebuild b/dev-cpp/mvfst/mvfst-2024.11.04.00-r1.ebuild
new file mode 100644
index 000000000000..396d42d484be
--- /dev/null
+++ b/dev-cpp/mvfst/mvfst-2024.11.04.00-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# These must be bumped together:
+# dev-cpp/edencommon
+# dev-cpp/fb303
+# dev-cpp/fbthrift
+# dev-cpp/fizz
+# dev-cpp/folly
+# dev-cpp/mvfst
+# dev-cpp/wangle
+# dev-util/watchman
+
+inherit cmake
+
+DESCRIPTION="An implementation of the QUIC transport protocol"
+HOMEPAGE="https://github.com/facebook/mvfst"
+SRC_URI="https://github.com/facebook/mvfst/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ~dev-cpp/fizz-${PV}:=
+ ~dev-cpp/folly-${PV}:=
+ dev-cpp/gflags:=
+ dev-cpp/glog:=[gflags]
+ dev-libs/boost:=
+ dev-libs/libfmt:=
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-cpp/gtest )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_MODULE_DIR="$(get_libdir)/cmake/${PN}"
+ -DCMAKE_INSTALL_LIBDIR="$(get_libdir)"
+ -DBUILD_TESTS="$(usex test ON OFF)"
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ if use arm64; then
+ # These tests segfault on arm64.
+ # https://github.com/facebook/mvfst/issues/363
+ CMAKE_SKIP_TESTS=(
+ QuicClientTransportIntegrationTest.ResetClient
+ QuicClientTransportIntegrationTest.TestStatelessResetToken
+ )
+ fi
+
+ cmake_src_test
+}