summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/mvfst/mvfst-2024.11.04.00.ebuild')
-rw-r--r--dev-cpp/mvfst/mvfst-2024.11.04.00.ebuild13
1 files changed, 13 insertions, 0 deletions
diff --git a/dev-cpp/mvfst/mvfst-2024.11.04.00.ebuild b/dev-cpp/mvfst/mvfst-2024.11.04.00.ebuild
index b920ce229a20..12d43e1df1c3 100644
--- a/dev-cpp/mvfst/mvfst-2024.11.04.00.ebuild
+++ b/dev-cpp/mvfst/mvfst-2024.11.04.00.ebuild
@@ -47,3 +47,16 @@ src_configure() {
cmake_src_configure
}
+
+src_test() {
+ if use arm64; then
+ # These tests segfault on arm64.
+ # https://github.com/facebook/mvfst/issues/363
+ CMAKE_SKIP_TESTS=(
+ QuicClientTransportIntegrationTest.ResetClient
+ QuicClientTransportIntegrationTest.TestStatelessResetToken
+ )
+ fi
+
+ cmake_src_test
+}