summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/nlohmann_json/nlohmann_json-3.10.5.ebuild')
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.10.5.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.10.5.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.10.5.ebuild
index 0ac3b7c9dd07..8bc260638ed9 100644
--- a/dev-cpp/nlohmann_json/nlohmann_json-3.10.5.ebuild
+++ b/dev-cpp/nlohmann_json/nlohmann_json-3.10.5.ebuild
@@ -3,6 +3,11 @@
EAPI=8
+#DOCS_BUILDER="mkdocs"
+# Needs unpackaged plantuml-markdown too
+# ... but plantuml (Python bindings anyway) need network access to generate bits at runtime.
+#DOCS_DEPEND="dev-python/mkdocs-material-extensions dev-python/mkdocs-minify-plugin"
+#DOCS_DIR="doc/mkdocs"
inherit cmake
# Check https://github.com/nlohmann/json/blob/develop/cmake/download_test_data.cmake to find test archive version
@@ -17,13 +22,11 @@ S="${WORKDIR}/json-${PV}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
-IUSE="doc test"
+IUSE="test"
# Need to report failing tests upstream
# Tests only just added, large test suite, majority pass
RESTRICT="test"
-BDEPEND="doc? ( app-doc/doxygen )"
-
DOCS=( ChangeLog.md README.md )
src_configure() {
@@ -41,11 +44,6 @@ src_configure() {
src_compile() {
cmake_src_compile
-
- if use doc; then
- emake -C doc
- HTML_DOCS=( doc/html/. )
- fi
}
src_test() {