summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/pangomm/pangomm-2.50.0-r1.ebuild')
-rw-r--r--dev-cpp/pangomm/pangomm-2.50.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-cpp/pangomm/pangomm-2.50.0-r1.ebuild b/dev-cpp/pangomm/pangomm-2.50.0-r1.ebuild
new file mode 100644
index 000000000000..f2daed7fcb79
--- /dev/null
+++ b/dev-cpp/pangomm/pangomm-2.50.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit gnome.org meson-multilib python-any-r1
+
+DESCRIPTION="C++ interface for pango"
+HOMEPAGE="https://www.gtkmm.org"
+
+LICENSE="LGPL-2.1+"
+SLOT="2.48"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="gtk-doc"
+
+DEPEND="
+ >=dev-cpp/cairomm-1.16.0:1.16[gtk-doc?,${MULTILIB_USEDEP}]
+ >=dev-cpp/glibmm-2.68.0:2.68[gtk-doc?,${MULTILIB_USEDEP}]
+ >=dev-libs/libsigc++-3:3[gtk-doc?,${MULTILIB_USEDEP}]
+ >=x11-libs/pango-1.49.4[${MULTILIB_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ gtk-doc? (
+ app-doc/doxygen[dot]
+ dev-lang/perl
+ dev-libs/libxslt
+ )
+ ${PYTHON_DEPS}
+"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dmaintainer-mode=false
+ $(meson_native_use_bool gtk-doc build-documentation)
+ )
+ meson_src_configure
+}