summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/wangle/wangle-2024.11.04.00.ebuild')
-rw-r--r--dev-cpp/wangle/wangle-2024.11.04.00.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-cpp/wangle/wangle-2024.11.04.00.ebuild b/dev-cpp/wangle/wangle-2024.11.04.00.ebuild
new file mode 100644
index 000000000000..15b6be4d72de
--- /dev/null
+++ b/dev-cpp/wangle/wangle-2024.11.04.00.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# These must be bumped together:
+# dev-cpp/edencommon
+# dev-cpp/fb303
+# dev-cpp/fbthrift
+# dev-cpp/fizz
+# dev-cpp/folly
+# dev-cpp/mvfst
+# dev-cpp/wangle
+# dev-util/watchman
+
+CMAKE_USE_DIR="${S}/wangle"
+
+inherit cmake
+
+DESCRIPTION="A framework providing common abstractions for building services"
+HOMEPAGE="https://github.com/facebook/wangle"
+SRC_URI="https://github.com/facebook/wangle/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ~dev-cpp/fizz-${PV}:=
+ ~dev-cpp/folly-${PV}:=
+ dev-cpp/gflags:=
+ dev-cpp/glog:=[gflags]
+ dev-libs/libevent:=
+ dev-libs/libfmt:=
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-cpp/gtest )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DIR="$(get_libdir)/cmake/${PN}"
+ -DLIB_INSTALL_DIR="$(get_libdir)"
+ -DBUILD_TESTS="$(usex test ON OFF)"
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ CMAKE_SKIP_TESTS=(
+ # These tests expect test certificates to be present in /usr/include/folly/io/async/test/certs/, which folly
+ # doesn't install.
+ SSLContextManagerTest
+ )
+
+ cmake_src_test
+}