summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/glibmm/Manifest1
-rw-r--r--dev-cpp/glibmm/glibmm-2.50.0.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-cpp/glibmm/Manifest b/dev-cpp/glibmm/Manifest
index dfcf1c43be44..5ef301522686 100644
--- a/dev-cpp/glibmm/Manifest
+++ b/dev-cpp/glibmm/Manifest
@@ -2,3 +2,4 @@ DIST glibmm-2.44.0.tar.xz 6102664 SHA256 1b0ac0425d24895507c0e0e8088a464c7ae2d28
DIST glibmm-2.46.3.tar.xz 6470984 SHA256 c78654addeb27a1213bedd7cd21904a45bbb98a5ba2f2f0de2b2f1a5682d86cf SHA512 24e112edd2bb6d2cf05a275d2ee781a4921f408dbb7fd317259c3303a993845a40f2e3e3fbaa819b88f718e25c30f02ad32695767eb6688a90389aea961b1a66 WHIRLPOOL e390fad02e5c254097b69302905a09d13c7abc6bcf3ca623b948de54004f601884397b7381c2b51d913879d2872a58d519249ba6af10dab3b0728dca013a6ad7
DIST glibmm-2.46.4.tar.xz 6473200 SHA256 bfec03899e49305f3c235025c676f3bc16602af7a62f2baaa6a9d0e358884b4d SHA512 871245b23307b7feb041d8964bc764622bb4aa1c6d879e06ffcafbe1bf8f14fae18d8d304c806114ac952a6ee0da8189f8d4cb9956d6059dab647d97b119ae4d WHIRLPOOL ca9d44ba39e90204e9ce6adcbd46f06df0ea82ab7687dc38f72f4f72b75e2550aa6e75a568e9fbe51e83babe6b7e5403facab608bd095d14bd33f4336282f145
DIST glibmm-2.48.1.tar.xz 6235724 SHA256 dc225f7d2f466479766332483ea78f82dc349d59399d30c00de50e5073157cdf SHA512 280949315e592ff8f3f7cfa6376d129211ffb6832146578d6533c4792aafef8b4ea5354943d5623ebf34ce31b8c71b6055a51de2b8ae8cfb419e6e033d9f98fa WHIRLPOOL 81c369bf7bf7ebc1f88e47943ed4b352644cad05566ec2fa04f0974a9e48dbc56b3cbd2f3bde9f55412da886e9b99fde096a1936834c65c77ede3781be30e0fd
+DIST glibmm-2.50.0.tar.xz 6435208 SHA256 df726e3c6ef42b7621474b03b644a2e40ec4eef94a1c5a932c1e740a78f95e94 SHA512 ed1043fbb5d16dfcb1e71f73e2c998110aa0dbc42b3fc9d8d1cc03e299b171021f2d2ac3055f5685d11b4dc1ddef42d9378eaac895163ddd80f39a627cecdc60 WHIRLPOOL b9c6867876311381b986f5123b6574bae01b45054e80a00c83688d756ed2a8e213dc3b1153a0aeb2672d9db998771fd6f538e1d592ffcb695ff7ac6147094975
diff --git a/dev-cpp/glibmm/glibmm-2.50.0.ebuild b/dev-cpp/glibmm/glibmm-2.50.0.ebuild
new file mode 100644
index 000000000000..3c577fa58759
--- /dev/null
+++ b/dev-cpp/glibmm/glibmm-2.50.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit gnome2 multilib-minimal
+
+DESCRIPTION="C++ interface for glib2"
+HOMEPAGE="http://www.gtkmm.org"
+
+LICENSE="LGPL-2.1+ GPL-2+" # GPL-2+ applies only to the build system
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc debug test"
+
+RDEPEND="
+ >=dev-libs/libsigc++-2.9.1:2[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.50.0:2[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+# dev-cpp/mm-common needed for eautoreconf
+
+src_prepare() {
+ if ! use test; then
+ # don't waste time building tests
+ sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die "sed 1 failed"
+ fi
+
+ # don't build examples - we want to install example sources, not binaries
+ sed 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die "sed 2 failed"
+
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" gnome2_src_configure \
+ $(use_enable debug debug-refcounting) \
+ $(multilib_native_use_enable doc documentation) \
+ --enable-deprecated-api
+}
+
+multilib_src_test() {
+ cd tests
+ default
+
+ for i in */test; do
+ ${i} || die "Running tests failed at ${i}"
+ done
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ find examples -type d -name '.deps' -exec rm -rf {} \; 2>/dev/null
+ find examples -type f -name 'Makefile*' -exec rm -f {} \; 2>/dev/null
+ dodoc -r examples
+}