summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/mariadb/mariadb-10.2.7.ebuild')
-rw-r--r--dev-db/mariadb/mariadb-10.2.7.ebuild14
1 files changed, 14 insertions, 0 deletions
diff --git a/dev-db/mariadb/mariadb-10.2.7.ebuild b/dev-db/mariadb/mariadb-10.2.7.ebuild
index b3a418dee7b7..9e83778c5928 100644
--- a/dev-db/mariadb/mariadb-10.2.7.ebuild
+++ b/dev-db/mariadb/mariadb-10.2.7.ebuild
@@ -108,6 +108,20 @@ pkg_preinst() {
fi
}
+pkg_postinst() {
+ mysql-multilib-r1_pkg_postinst
+
+ # Note about configuration change
+ einfo
+ elog "This version of mariadb reorganizes the configuration from a single my.cnf"
+ elog "to several files in /etc/mysql/${PN}.d."
+ elog "Please backup any changes you made to /etc/mysql/my.cnf"
+ elog "and add them as a new file under /etc/mysql/${PN}.d with a .cnf extension."
+ elog "You may have as many files as needed and they are read alphabetically."
+ elog "Be sure the options have the appropitate section headers, i.e. [mysqld]."
+ einfo
+}
+
src_prepare() {
java-pkg-opt-2_src_prepare
if use tcmalloc; then