summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/pgadmin3')
-rw-r--r--dev-db/pgadmin3/Manifest1
-rw-r--r--dev-db/pgadmin3/pgadmin3-1.22.0.ebuild59
2 files changed, 0 insertions, 60 deletions
diff --git a/dev-db/pgadmin3/Manifest b/dev-db/pgadmin3/Manifest
index 795ca1f93add..fc4732a14954 100644
--- a/dev-db/pgadmin3/Manifest
+++ b/dev-db/pgadmin3/Manifest
@@ -1,2 +1 @@
-DIST pgadmin3-1.22.0.tar.gz 14668096 SHA256 3c76c429797a9524f00d4dd82ab77aa367f2bba154c2b2e017de5cbc9d690256 SHA512 db16ac1b92e95a6da51be973b6833e53aed4c1d8740c8bccbfd778b0c3d3a4158fb13107761e0a39227aea87360be3b297ebc8809ac8ca5102d673935a33727c WHIRLPOOL 2282b70c4579f2ad5b83c94cfa62429f1825e387e5864db8cf74631b1bbd340d4031c6d5a50947c1fdd8a15c3b732fe69a90fef1c38fd109de9d5f3ae8d007ca
DIST pgadmin3-1.22.1.tar.gz 14667770 SHA256 719ea7c0e65d99e8f365bf2d395d7a199804170b3266ada1374d9ac790bc783e SHA512 f190e82317e10b75cb0ebd7cc0c878c4be9c392e33aba44a1356446e4cac92735834a32b1d65999ffc3e36ed130d4cfcc1c25ad5faa3c745e884fccd797331e0 WHIRLPOOL ce7291cd0257914d6c5c11b71f0de630d9b72ac1ec9ee890a4b1feffed540c751c16e4164544223bb7db0eca02d1798d83f188362db4b750c504fd44aad081b7
diff --git a/dev-db/pgadmin3/pgadmin3-1.22.0.ebuild b/dev-db/pgadmin3/pgadmin3-1.22.0.ebuild
deleted file mode 100644
index 07deeb5b98e7..000000000000
--- a/dev-db/pgadmin3/pgadmin3-1.22.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils multilib versionator wxwidgets
-
-DESCRIPTION="wxWidgets GUI for PostgreSQL"
-HOMEPAGE="http://www.pgadmin.org/"
-SRC_URI="mirror://postgresql/${PN}/release/v${PV}/src/${P}.tar.gz"
-
-LICENSE="POSTGRESQL"
-KEYWORDS="amd64 ppc x86 ~x86-fbsd"
-SLOT="0"
-IUSE="debug +databasedesigner"
-
-DEPEND="x11-libs/wxGTK:=[X,debug=]
- >=dev-db/postgresql-8.4.0:=
- >=dev-libs/libxml2-2.6.18
- >=dev-libs/libxslt-1.1"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- local pgslot=$(postgresql-config show)
-
- if [[ ${pgslot//.} < 84 ]] ; then
- eerror "PostgreSQL slot must be set to 8.4 or higher."
- eerror " postgresql-config set 8.4"
- die "PostgreSQL slot is not set to 8.4 or higher."
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}/pgadmin3-desktop.patch"
-
- epatch_user
-}
-
-src_configure() {
- WX_GTK_PV=$(best_version x11-libs/wxGTK[X,debug=])
- WX_GTK_VER=$(get_version_component_range 1-2 ${WX_GTK_PV#x11-libs/wxGTK-})
-
- need-wxwidgets unicode
-
- econf --with-wx-version=${WX_GTK_VER} \
- $(use_enable debug) \
- $(use_enable databasedesigner)
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- newicon "${S}/pgadmin/include/images/pgAdmin3.png" ${PN}.png
-
- domenu "${S}/pkg/pgadmin3.desktop"
-
- # Fixing world-writable files
- fperms -R go-w /usr/share
-}