summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/pgpool2/pgpool2-9999.ebuild')
-rw-r--r--dev-db/pgpool2/pgpool2-9999.ebuild20
1 files changed, 7 insertions, 13 deletions
diff --git a/dev-db/pgpool2/pgpool2-9999.ebuild b/dev-db/pgpool2/pgpool2-9999.ebuild
index 042e87ed4a92..2b63038d42ff 100644
--- a/dev-db/pgpool2/pgpool2-9999.ebuild
+++ b/dev-db/pgpool2/pgpool2-9999.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
EGIT_REPO_URI="https://git.postgresql.org/git/pgpool2.git"
-POSTGRES_COMPAT=( 9.{5..6} {10..11} )
+POSTGRES_COMPAT=( 9.{5..6} {10..13} )
inherit autotools git-r3 postgres-multi
@@ -30,7 +30,6 @@ RDEPEND="
)
"
DEPEND="${RDEPEND}
- !!dev-db/pgpool
sys-devel/bison
virtual/pkgconfig
doc? (
@@ -48,10 +47,10 @@ pkg_setup() {
src_prepare() {
eapply \
- "${FILESDIR}/pgpool-configure-memcached.patch" \
+ "${FILESDIR}/pgpool-4.2.0-configure-memcached.patch" \
"${FILESDIR}/pgpool-configure-pam.patch" \
- "${FILESDIR}/pgpool-configure-pthread.patch" \
- "${FILESDIR}/pgpool_run_paths-3.7.10.patch"
+ "${FILESDIR}/pgpool-4.2.0-configure-pthread.patch" \
+ "${FILESDIR}/pgpool-4.2.0-run_paths.patch"
eautoreconf
@@ -61,7 +60,7 @@ src_prepare() {
src_configure() {
postgres-multi_foreach econf \
--disable-rpath \
- --sysconfdir="${EROOT%/}/etc/${PN}" \
+ --sysconfdir="${EROOT}/etc/${PN}" \
--with-pgsql-includedir='/usr/include/postgresql-@PG_SLOT@' \
--with-pgsql-libdir="/usr/$(get_libdir)/postgresql-@PG_SLOT@/$(get_libdir)" \
$(use_enable static-libs static) \
@@ -93,14 +92,9 @@ src_install() {
dodoc NEWS TODO
use doc && postgres-multi_forbest emake DESTDIR="${D}" -C doc install
- # Examples and extras
# mv some files that get installed to /usr/share/pgpool-II so that
# they all wind up in the same place
- mv "${ED%/}/usr/share/${PN/2/-II}" "${ED%/}/usr/share/${PN}" || die
- into "/usr/share/${PN}"
- dobin src/sample/{pgpool_recovery,pgpool_recovery_pitr,pgpool_remote_start}
- insinto "/usr/share/${PN}"
- doins src/sample/{{pcp,pgpool,pool_hba}.conf.sample*,pgpool.pam}
+ mv "${ED}/usr/share/${PN/2/-II}" "${ED}/usr/share/${PN}" || die
# One more thing: Evil la files!
find "${ED}" -name '*.la' -exec rm -f {} +