summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/timescaledb')
-rw-r--r--dev-db/timescaledb/timescaledb-2.0.1-r1.ebuild (renamed from dev-db/timescaledb/timescaledb-2.0.1.ebuild)6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-db/timescaledb/timescaledb-2.0.1.ebuild b/dev-db/timescaledb/timescaledb-2.0.1-r1.ebuild
index 26e21a09813f..9e97e6124c15 100644
--- a/dev-db/timescaledb/timescaledb-2.0.1.ebuild
+++ b/dev-db/timescaledb/timescaledb-2.0.1-r1.ebuild
@@ -36,8 +36,10 @@ timescale_configure() {
local CMAKE_USE_DIR=$BUILD_DIR
local mycmakeargs=( "-DPG_CONFIG=/usr/bin/pg_config${MULTIBUILD_VARIANT}" "-DREGRESS_CHECKS=OFF" )
- # licensing is tied to features, this useflag disables the non-apache2 licensed bits"
- use proprietary-extensions || mycmakeargs += "-DAPACHE_ONLY=ON"
+ # licensing is tied to features, this useflag disables the non-apache2 licensed bits
+ if ! use proprietary-extensions ; then
+ mycmakeargs+=("-DAPACHE_ONLY=ON")
+ fi
cmake_src_configure
}