summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet/gnome-sharp/gnome-sharp-2.24.2-r1.ebuild')
-rw-r--r--dev-dotnet/gnome-sharp/gnome-sharp-2.24.2-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-dotnet/gnome-sharp/gnome-sharp-2.24.2-r1.ebuild b/dev-dotnet/gnome-sharp/gnome-sharp-2.24.2-r1.ebuild
new file mode 100644
index 000000000000..604e7652e7b5
--- /dev/null
+++ b/dev-dotnet/gnome-sharp/gnome-sharp-2.24.2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit dotnet autotools base
+
+SLOT="2"
+DESCRIPTION="gnome bindings for mono"
+HOMEPAGE="http://www.mono-project.com/GtkSharp"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~ppc ~x86-fbsd"
+SRC_URI="mirror://gnome/sources/gnome-sharp/2.24/${P}.tar.bz2"
+IUSE="debug"
+
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-dotnet/gtk-sharp-2.12.21:2
+ gnome-base/gconf
+ gnome-base/libgnomecanvas
+ gnome-base/libgnomeui
+ media-libs/libart_lgpl
+ !dev-dotnet/gnomevfs-sharp
+ !dev-dotnet/gconf-sharp
+ !dev-dotnet/art-sharp
+ "
+DEPEND="${RDEPEND}
+ sys-devel/automake:1.11"
+
+src_prepare() {
+ base_src_prepare
+ eautoreconf
+ elibtoolize
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_install() {
+ default
+ dotnet_multilib_comply
+}