summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded/scratchbox-devkit-svn/scratchbox-devkit-svn-1.0.ebuild')
-rw-r--r--dev-embedded/scratchbox-devkit-svn/scratchbox-devkit-svn-1.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-embedded/scratchbox-devkit-svn/scratchbox-devkit-svn-1.0.ebuild b/dev-embedded/scratchbox-devkit-svn/scratchbox-devkit-svn-1.0.ebuild
new file mode 100644
index 000000000000..28e82ddc0d25
--- /dev/null
+++ b/dev-embedded/scratchbox-devkit-svn/scratchbox-devkit-svn-1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+SBOX_GROUP="sbox"
+
+DESCRIPTION="A cross-compilation toolkit designed to make embedded Linux application development easier"
+HOMEPAGE="http://www.scratchbox.org/"
+SRC_URI="http://scratchbox.org/download/files/sbox-releases/stable/tarball/${P}-i386.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Stripping BREAKS scratchbox, it runs in a chroot and is pre-stripped when needed (bug #296294)
+RESTRICT="strip"
+
+RDEPEND="=dev-embedded/scratchbox-1.0*"
+DEPEND=""
+
+TARGET_DIR="/opt/scratchbox"
+
+QA_TEXTRELS="opt/scratchbox"
+
+S=${WORKDIR}/scratchbox
+
+src_install() {
+ dodir ${TARGET_DIR}
+ cp -pRP * "${D}/${TARGET_DIR}"
+}