summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-go/go-sys/go-sys-0_pre20180816.ebuild')
-rw-r--r--dev-go/go-sys/go-sys-0_pre20180816.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-go/go-sys/go-sys-0_pre20180816.ebuild b/dev-go/go-sys/go-sys-0_pre20180816.ebuild
deleted file mode 100644
index e42e90c0451b..000000000000
--- a/dev-go/go-sys/go-sys-0_pre20180816.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-EGO_PN=golang.org/x/sys/...
-
-if [[ ${PV} = *9999* ]]; then
- inherit golang-vcs
-else
- KEYWORDS="~amd64 ~arm ~x86"
- EGIT_COMMIT="1c9583448a9c3aa0f9a6a5241bf73c0bd8aafded"
- SRC_URI="https://github.com/golang/sys/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- inherit golang-vcs-snapshot
-fi
-inherit golang-build
-
-DESCRIPTION="Go packages for low-level interaction with the operating system"
-HOMEPAGE="https://godoc.org/golang.org/x/sys"
-LICENSE="BSD"
-SLOT="0/${PVR}"
-IUSE=""
-DEPEND=""
-RDEPEND=""
-
-src_compile() {
- GOPATH="${S}" \
- go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}" || die
-}
-
-src_test() {
- GOPATH="${S}" \
- go test -v -work -x "${EGO_PN}" || die
-}
-
-src_install() {
- golang_install_pkgs
-}