summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/aeson-pretty/aeson-pretty-0.8.2.ebuild')
-rw-r--r--dev-haskell/aeson-pretty/aeson-pretty-0.8.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/aeson-pretty/aeson-pretty-0.8.2.ebuild b/dev-haskell/aeson-pretty/aeson-pretty-0.8.2.ebuild
new file mode 100644
index 000000000000..74e2fb8cccee
--- /dev/null
+++ b/dev-haskell/aeson-pretty/aeson-pretty-0.8.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="JSON pretty-printing library and command-line tool"
+HOMEPAGE="https://github.com/informatikr/aeson-pretty"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="lib-only"
+
+RDEPEND=">=dev-haskell/aeson-0.7:=[profile?]
+ >=dev-haskell/base-compat-0.9:=[profile?] <dev-haskell/base-compat-0.10:=[profile?]
+ >=dev-haskell/scientific-0.3:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-haskell/unordered-containers-0.1.3.0:=[profile?]
+ >=dev-haskell/vector-0.9:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ !lib-only? ( >=dev-haskell/attoparsec-0.10:=[profile?]
+ >=dev-haskell/cmdargs-0.7:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag lib-only lib-only)
+}