summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/attoparsec-iso8601/attoparsec-iso8601-1.0.2.1.ebuild')
-rw-r--r--dev-haskell/attoparsec-iso8601/attoparsec-iso8601-1.0.2.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/attoparsec-iso8601/attoparsec-iso8601-1.0.2.1.ebuild b/dev-haskell/attoparsec-iso8601/attoparsec-iso8601-1.0.2.1.ebuild
new file mode 100644
index 000000000000..d1abf2973fd2
--- /dev/null
+++ b/dev-haskell/attoparsec-iso8601/attoparsec-iso8601-1.0.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+#hackport: flags: -developer,+fast
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Parsing of ISO 8601 dates, originally from aeson"
+HOMEPAGE="https://github.com/haskell/aeson"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-haskell/attoparsec-0.14.2:=[profile?] <dev-haskell/attoparsec-0.15:=[profile?]
+ >=dev-haskell/base-compat-batteries-0.10.0:=[profile?] <dev-haskell/base-compat-batteries-0.13:=[profile?]
+ >=dev-haskell/time-compat-1.9.4:=[profile?] <dev-haskell/time-compat-1.10:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-developer \
+ --flag=fast
+}