summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/bitwise/bitwise-0.1.1.1.ebuild')
-rw-r--r--dev-haskell/bitwise/bitwise-0.1.1.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/bitwise/bitwise-0.1.1.1.ebuild b/dev-haskell/bitwise/bitwise-0.1.1.1.ebuild
new file mode 100644
index 000000000000..4cee11ce3c00
--- /dev/null
+++ b/dev-haskell/bitwise/bitwise-0.1.1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="fast multi-dimensional unboxed bit packed Bool arrays"
+HOMEPAGE="http://code.mathr.co.uk/bitwise"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.9.2
+ test? ( >=dev-haskell/quickcheck-2.4 )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'QuickCheck >= 2.4 && < 2.9' 'QuickCheck >= 2.4'
+}