summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/chasingbottoms/chasingbottoms-1.3.0.8-r1.ebuild')
-rw-r--r--dev-haskell/chasingbottoms/chasingbottoms-1.3.0.8-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-haskell/chasingbottoms/chasingbottoms-1.3.0.8-r1.ebuild b/dev-haskell/chasingbottoms/chasingbottoms-1.3.0.8-r1.ebuild
new file mode 100644
index 000000000000..441e70fdf8b4
--- /dev/null
+++ b/dev-haskell/chasingbottoms/chasingbottoms-1.3.0.8-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.2.9999
+#hackport: flags: -build-tests
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="ChasingBottoms"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="For testing partial and infinite values"
+HOMEPAGE="http://hackage.haskell.org/package/ChasingBottoms"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-1.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/quickcheck-2.1:2=[profile?] <dev-haskell/quickcheck-2.8:2=[profile?]
+ >=dev-haskell/random-1.0:=[profile?] <dev-haskell/random-1.2:=[profile?]
+ >=dev-haskell/syb-0.1.0.2:=[profile?] <dev-haskell/syb-0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ cabal_chdeps \
+ 'random == 1.0.*' 'random >= 1.0 && < 1.2'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-build-tests
+}