summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/cmdargs/cmdargs-0.10.14.ebuild')
-rw-r--r--dev-haskell/cmdargs/cmdargs-0.10.14.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-haskell/cmdargs/cmdargs-0.10.14.ebuild b/dev-haskell/cmdargs/cmdargs-0.10.14.ebuild
new file mode 100644
index 000000000000..e45080ef300d
--- /dev/null
+++ b/dev-haskell/cmdargs/cmdargs-0.10.14.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Command line argument processing"
+HOMEPAGE="https://github.com/ndmitchell/cmdargs#readme"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+quotation testprog"
+
+RDEPEND=">=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag quotation quotation) \
+ $(cabal_flag testprog testprog)
+}