summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/configfile/configfile-1.1.1.ebuild')
-rw-r--r--dev-haskell/configfile/configfile-1.1.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-haskell/configfile/configfile-1.1.1.ebuild b/dev-haskell/configfile/configfile-1.1.1.ebuild
new file mode 100644
index 000000000000..1f7e1be66228
--- /dev/null
+++ b/dev-haskell/configfile/configfile-1.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# ebuild generated by hackport 0.2.17.9999
+
+EAPI=4
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="ConfigFile"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Configuration file reading & writing"
+HOMEPAGE="http://software.complete.org/configfile"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/missingh-1.0.0[profile?]
+ dev-haskell/mtl[profile?]
+ dev-haskell/parsec[profile?]
+ >=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2.3"
+
+S="${WORKDIR}/${MY_P}"