summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/cryptocipher/cryptocipher-0.5.2.ebuild')
-rw-r--r--dev-haskell/cryptocipher/cryptocipher-0.5.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/cryptocipher/cryptocipher-0.5.2.ebuild b/dev-haskell/cryptocipher/cryptocipher-0.5.2.ebuild
new file mode 100644
index 000000000000..6aff4c227778
--- /dev/null
+++ b/dev-haskell/cryptocipher/cryptocipher-0.5.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.3.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Symmetrical block and stream ciphers"
+HOMEPAGE="http://github.com/vincenthz/hs-crypto-cipher"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/cereal:=[profile?]
+ dev-haskell/cipher-aes:=[profile?]
+ dev-haskell/cipher-rc4:=[profile?]
+ =dev-haskell/cpu-0.1*:=[profile?]
+ >=dev-haskell/crypto-api-0.5:=[profile?]
+ dev-haskell/primitive:=[profile?]
+ >=dev-haskell/vector-0.7:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ "
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/cryptohash
+ dev-haskell/entropy
+ >=dev-haskell/quickcheck-2
+ >=dev-haskell/test-framework-0.3.3
+ >=dev-haskell/test-framework-quickcheck2-0.2.9
+ )"