summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/cryptohash-sha1/cryptohash-sha1-0.11.100.1.ebuild')
-rw-r--r--dev-haskell/cryptohash-sha1/cryptohash-sha1-0.11.100.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/cryptohash-sha1/cryptohash-sha1-0.11.100.1.ebuild b/dev-haskell/cryptohash-sha1/cryptohash-sha1-0.11.100.1.ebuild
new file mode 100644
index 000000000000..c53c2bcf8aa6
--- /dev/null
+++ b/dev-haskell/cryptohash-sha1/cryptohash-sha1-0.11.100.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast, pure and practical SHA-1 implementation"
+HOMEPAGE="https://github.com/hvr/cryptohash-sha1"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( >=dev-haskell/base16-bytestring-0.1.1 <dev-haskell/base16-bytestring-0.2
+ >=dev-haskell/sha-1.6.4 <dev-haskell/sha-1.7
+ >=dev-haskell/tasty-0.11
+ >=dev-haskell/tasty-hunit-0.9
+ >=dev-haskell/tasty-quickcheck-0.8 )
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'base >= 4.5 && < 4.10' 'base >= 4.5' \
+ 'tasty == 0.11.*' 'tasty >= 0.11' \
+ 'tasty-quickcheck == 0.8.*' 'tasty-quickcheck >= 0.8' \
+ 'tasty-hunit == 0.9.*' 'tasty-hunit >= 0.9'
+ default
+}