summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/esqueleto/esqueleto-2.1.2.1.ebuild')
-rw-r--r--dev-haskell/esqueleto/esqueleto-2.1.2.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-haskell/esqueleto/esqueleto-2.1.2.1.ebuild b/dev-haskell/esqueleto/esqueleto-2.1.2.1.ebuild
new file mode 100644
index 000000000000..58d232b122c0
--- /dev/null
+++ b/dev-haskell/esqueleto/esqueleto-2.1.2.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+#hackport: flags: -mysql,-postgresql
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Type-safe EDSL for SQL queries on persistent backends"
+HOMEPAGE="https://github.com/prowdsponsor/esqueleto"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # tests hang
+
+RDEPEND=">=dev-haskell/conduit-1.1:=[profile?]
+ dev-haskell/monad-logger:=[profile?]
+ >=dev-haskell/persistent-2.1:=[profile?] <dev-haskell/persistent-2.2:=[profile?]
+ >=dev-haskell/resourcet-1.1:=[profile?]
+ >=dev-haskell/tagged-0.2:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-haskell/unordered-containers-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.8
+ dev-haskell/hunit
+ dev-haskell/monad-control
+ >=dev-haskell/monad-logger-0.3
+ >=dev-haskell/persistent-sqlite-2.1 <dev-haskell/persistent-sqlite-2.2
+ >=dev-haskell/persistent-template-2.1 <dev-haskell/persistent-template-2.2
+ dev-haskell/quickcheck )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-mysql \
+ --flag=-postgresql
+}