summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/extra/extra-1.7.10.ebuild')
-rw-r--r--dev-haskell/extra/extra-1.7.10.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/dev-haskell/extra/extra-1.7.10.ebuild b/dev-haskell/extra/extra-1.7.10.ebuild
index 060084625003..ca17f8702594 100644
--- a/dev-haskell/extra/extra-1.7.10.ebuild
+++ b/dev-haskell/extra/extra-1.7.10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,12 +13,20 @@ HOMEPAGE="https://github.com/ndmitchell/extra#readme"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
-SLOT="2/${PV}"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
RDEPEND=">=dev-haskell/clock-0.7:=[profile?]
>=dev-lang/ghc-8.4.3:=
"
+
+# Tests do not work correctly on >=ghc-9.2
+RDEPEND+="
+ test? (
+ <dev-lang/ghc-9.1
+ )
+"
+
DEPEND="${RDEPEND}
>=dev-haskell/cabal-2.2.0.1
test? ( >=dev-haskell/quickcheck-2.10