summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/haxml')
-rw-r--r--dev-haskell/haxml/Manifest4
-rw-r--r--dev-haskell/haxml/files/haxml-1.23.3-haddock.patch12
-rw-r--r--dev-haskell/haxml/files/haxml-1.25-haddock.patch26
-rw-r--r--dev-haskell/haxml/haxml-1.24.1.ebuild32
-rw-r--r--dev-haskell/haxml/haxml-1.24.ebuild32
-rw-r--r--dev-haskell/haxml/haxml-1.25.3.ebuild32
-rw-r--r--dev-haskell/haxml/haxml-1.25.ebuild33
-rw-r--r--dev-haskell/haxml/metadata.xml8
8 files changed, 179 insertions, 0 deletions
diff --git a/dev-haskell/haxml/Manifest b/dev-haskell/haxml/Manifest
new file mode 100644
index 000000000000..b135a5fded51
--- /dev/null
+++ b/dev-haskell/haxml/Manifest
@@ -0,0 +1,4 @@
+DIST HaXml-1.24.1.tar.gz 142739 SHA256 5f258c7c6291ad54bb9a65280dd30efcbca3fc79a499d5b6575a753d3f7b78df SHA512 421f3a61e8eebf5ad915551c51dcd843a544e7959b93d6dd4ab2ffc6c20954f559da75dcfecc6fea838f80dc4d3c83243be3ce7a21e92bc165b3e0be120451bf WHIRLPOOL a60283d94937f0f5324b61ebd11c87c5d48a3ccc003e32ed85a95661a9f3980644c9491d558dfeb406b67c6374f4cdf923f5fe0e60639f4e0e0890c916077877
+DIST HaXml-1.24.tar.gz 143107 SHA256 b6f9b147f80dbac04b11633d0bd9309c7ce9d2b0cff67b83086212a4f0567ba2 SHA512 421864e4177b16f485b72d33210a67914c2040664d604db5cc70b356a518114f11dbcc1b1c8f300fd045338605613a14317bd5bf5f041a8e38990d3c5dc7e94c WHIRLPOOL 7d2bee34221d932847fb208003090997545e543ab29338673e3e23e0b895cfe982985e78ec68a17e9973ced866711d9fbc42b8a4beb14e99ef6b7d7fe3f6994e
+DIST HaXml-1.25.3.tar.gz 144189 SHA256 6448a7ee1c26159c6c10db93757ed9248f647b1c0c431e7aead6aadd6d2307c7 SHA512 b80a70954a79c9246ed9e92ca2bd7c94f54b2843eb387fa2045652cfa5eee69b8bfae17ef88b391855abe3dc672e3cf212be53e275e6ff350fe1074fff608828 WHIRLPOOL 3069482963f2d2c49943428d388d340d2eef055cf79089ef4f15b297adcf012e1aed44bea54a7d163e54c21f81777c56b1b71ef2badba69471122d6fc4772e5b
+DIST HaXml-1.25.tar.gz 144134 SHA256 936abb254607aa270a1a3d4102a098041f71ef38290cfd7fb9f363c4d21e850a SHA512 3b71af91601e3a5df933007a986ba9bb81a9cffeeb57f1e520f27788b52ad1deaa28ac25731797a8c4754e87465a007752366af50922d7e6b3c1947497ec9963 WHIRLPOOL a0093da0776ed7a03197c8b222aa02ae5e360b9e0bba018a251990072fae3c331e0dfd5fda26098f26874e6a64a1a7cb0a2adb3aa81dfb67b6e840213d466544
diff --git a/dev-haskell/haxml/files/haxml-1.23.3-haddock.patch b/dev-haskell/haxml/files/haxml-1.23.3-haddock.patch
new file mode 100644
index 000000000000..1da171b17678
--- /dev/null
+++ b/dev-haskell/haxml/files/haxml-1.23.3-haddock.patch
@@ -0,0 +1,12 @@
+--- HaXml-1.23.3-orig/src/Text/XML/HaXml/Schema/HaskellTypeModel.hs 2012-06-19 01:31:18.000000000 +1000
++++ HaXml-1.23.3/src/Text/XML/HaXml/Schema/HaskellTypeModel.hs 2012-06-19 01:49:23.784392420 +1000
+@@ -77,8 +77,8 @@
+ -- rests with the input doc, not with the caller of the parser.
+ | ElementsAttrsAbstract {-typename-}XName
+ {-subtypes-}[(XName,Maybe XName)]
+- -- ^ [(type name, module where declared later)]
+ Comment
++ -- ^ [(type name, module where declared later)]
+
+ -- becomes function
+ -- elementE :: Parser T
diff --git a/dev-haskell/haxml/files/haxml-1.25-haddock.patch b/dev-haskell/haxml/files/haxml-1.25-haddock.patch
new file mode 100644
index 000000000000..fbfdaf878c34
--- /dev/null
+++ b/dev-haskell/haxml/files/haxml-1.25-haddock.patch
@@ -0,0 +1,26 @@
+--- HaXml-1.25-orig/src/Text/XML/HaXml/Schema/TypeConversion.hs 2014-10-29 02:53:24.000000000 +1100
++++ HaXml-1.25/src/Text/XML/HaXml/Schema/TypeConversion.hs 2014-12-08 13:32:58.799433615 +1100
+@@ -38,7 +38,7 @@
+ Just (Right
+ (ComplexType
+ {complex_name=Just t'}))
+- {-| t==t'-}
++ {- | t==t' -}
+ -> (e:)
+ _ -> id
+ _ -> id
+@@ -75,10 +75,10 @@
+ renameSimple n s@UnionOf{} = s{ simple_name = Just n }
+
+
+--- * For now, rather than walk the tree, giving typenames to nodes that were
+--- previously locally-typed, we will instead assume in the pretty-printer
+--- that it can always replace a missing typename with the element name, and
+--- have it resolve to something sensible.
++ -- * For now, rather than walk the tree, giving typenames to nodes that were
++ -- previously locally-typed, we will instead assume in the pretty-printer
++ -- that it can always replace a missing typename with the element name, and
++ -- have it resolve to something sensible.
+ renameLocals :: SchemaItem -> SchemaItem
+ renameLocals s = s
+ -- renameLocals (SchemaElement e)
diff --git a/dev-haskell/haxml/haxml-1.24.1.ebuild b/dev-haskell/haxml/haxml-1.24.1.ebuild
new file mode 100644
index 000000000000..33280a94e112
--- /dev/null
+++ b/dev-haskell/haxml/haxml-1.24.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="HaXml"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Utilities for manipulating XML documents"
+HOMEPAGE="http://www.cs.york.ac.uk/fp/HaXml/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/polyparse-1.9:=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-haskell/haxml/haxml-1.24.ebuild b/dev-haskell/haxml/haxml-1.24.ebuild
new file mode 100644
index 000000000000..99408966e90c
--- /dev/null
+++ b/dev-haskell/haxml/haxml-1.24.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit base haskell-cabal
+
+MY_PN="HaXml"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Utilities for manipulating XML documents"
+HOMEPAGE="http://www.cs.york.ac.uk/fp/HaXml/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/polyparse-1.9:=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=("${FILESDIR}/${PN}-1.23.3-haddock.patch")
diff --git a/dev-haskell/haxml/haxml-1.25.3.ebuild b/dev-haskell/haxml/haxml-1.25.3.ebuild
new file mode 100644
index 000000000000..9587e167716b
--- /dev/null
+++ b/dev-haskell/haxml/haxml-1.25.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="HaXml"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Utilities for manipulating XML documents"
+HOMEPAGE="http://projects.haskell.org/HaXml/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/polyparse-1.10:=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-haskell/haxml/haxml-1.25.ebuild b/dev-haskell/haxml/haxml-1.25.ebuild
new file mode 100644
index 000000000000..85fe72a16137
--- /dev/null
+++ b/dev-haskell/haxml/haxml-1.25.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit base haskell-cabal
+
+MY_PN="HaXml"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Utilities for manipulating XML documents"
+HOMEPAGE="http://projects.haskell.org/HaXml/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/polyparse-1.10:=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2
+"
+PATCHES=("${FILESDIR}"/${PN}-1.25-haddock.patch)
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-haskell/haxml/metadata.xml b/dev-haskell/haxml/metadata.xml
new file mode 100644
index 000000000000..8c66906af531
--- /dev/null
+++ b/dev-haskell/haxml/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>haskell</herd>
+<maintainer>
+ <email>haskell@gentoo.org</email>
+</maintainer>
+</pkgmetadata>