summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/http-client/http-client-0.6.4.1.ebuild')
-rw-r--r--dev-haskell/http-client/http-client-0.6.4.1.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-haskell/http-client/http-client-0.6.4.1.ebuild b/dev-haskell/http-client/http-client-0.6.4.1.ebuild
deleted file mode 100644
index 023cfce84a64..000000000000
--- a/dev-haskell/http-client/http-client-0.6.4.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.6.5.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="An HTTP client engine, intended as a base layer for more user-friendly packages"
-HOMEPAGE="https://github.com/snoyberg/http-client"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="+network-uri"
-
-RESTRICT=test # requires network access
-
-RDEPEND=">=dev-haskell/blaze-builder-0.3:=[profile?]
- >=dev-haskell/case-insensitive-1.0:=[profile?]
- dev-haskell/cookie:=[profile?]
- >=dev-haskell/exceptions-0.4:=[profile?]
- >=dev-haskell/http-types-0.8:=[profile?]
- >=dev-haskell/memory-0.7:=[profile?]
- dev-haskell/mime-types:=[profile?]
- dev-haskell/random:=[profile?]
- >=dev-haskell/stm-2.3:=[profile?]
- >=dev-haskell/streaming-commons-0.1.0.2:=[profile?] <dev-haskell/streaming-commons-0.3:=[profile?]
- >=dev-haskell/text-0.11:=[profile?]
- >=dev-lang/ghc-8.2.1:=
- network-uri? ( >=dev-haskell/network-2.6:=[profile?]
- >=dev-haskell/network-uri-2.6:=[profile?] )
- !network-uri? ( >=dev-haskell/network-2.4:=[profile?] <dev-haskell/network-2.6:=[profile?] )
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-2.0.0.2
- test? ( dev-haskell/async
- dev-haskell/hspec
- dev-haskell/monad-control
- >=dev-haskell/streaming-commons-0.1.1
- dev-haskell/zlib
- !network-uri? ( dev-haskell/network-uri ) )
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag network-uri network-uri)
-}