summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/monad-par/monad-par-0.3.4.7.ebuild')
-rw-r--r--dev-haskell/monad-par/monad-par-0.3.4.7.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-haskell/monad-par/monad-par-0.3.4.7.ebuild b/dev-haskell/monad-par/monad-par-0.3.4.7.ebuild
new file mode 100644
index 000000000000..84141b625027
--- /dev/null
+++ b/dev-haskell/monad-par/monad-par-0.3.4.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+#hackport: flags: -newgeneric
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A library for parallel programming based on a monad"
+HOMEPAGE="https://github.com/simonmar/monad-par"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="chaselev"
+
+RDEPEND=">=dev-haskell/abstract-deque-0.1.4:=[profile?]
+ dev-haskell/abstract-par:=[profile?]
+ >=dev-haskell/monad-par-extras-0.3:=[profile?]
+ >=dev-haskell/mtl-2.0.1.0:=[profile?]
+ >=dev-haskell/mwc-random-0.11:=[profile?]
+ >=dev-haskell/parallel-3.1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ chaselev? ( dev-haskell/chaselev-deque:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ dev-haskell/quickcheck
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ >=dev-haskell/test-framework-quickcheck2-0.3
+ dev-haskell/test-framework-th )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag chaselev chaselev) \
+ --flag=-newgeneric
+}