summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/monads-tf')
-rw-r--r--dev-haskell/monads-tf/Manifest2
-rw-r--r--dev-haskell/monads-tf/metadata.xml14
-rw-r--r--dev-haskell/monads-tf/monads-tf-0.1.0.1-r1.ebuild25
-rw-r--r--dev-haskell/monads-tf/monads-tf-0.1.0.1.ebuild25
-rw-r--r--dev-haskell/monads-tf/monads-tf-0.1.0.2.ebuild26
5 files changed, 92 insertions, 0 deletions
diff --git a/dev-haskell/monads-tf/Manifest b/dev-haskell/monads-tf/Manifest
new file mode 100644
index 000000000000..6a552cae5a93
--- /dev/null
+++ b/dev-haskell/monads-tf/Manifest
@@ -0,0 +1,2 @@
+DIST monads-tf-0.1.0.1.tar.gz 14198 SHA256 3b546924435647cc366eaffb6cd0082255de0290931adf2fc72bf3afa208eaa7 SHA512 ea087bc58e4116accdb8d210d66a6ebdbe927ffacebc6f80aaf9fe288541eb1f721d846243aa9098e7f23c145845b508c1ead75e7892eb5a372a22b45fd9ec35 WHIRLPOOL 788fe173677f324864895d6ac450ac64daa5757a56f324ce1558179a7e40b98b1ed65ac736cfd7f744d112a1379bb3e9bf3785f03d5d79c915934e0b8f2bf36d
+DIST monads-tf-0.1.0.2.tar.gz 14206 SHA256 cb6f495443f526b00b3d06535aa29e393473244acd410cba1b898eeaa8f8077c SHA512 5539d735f3d638a700a36e1d3cf0a96dbfd15f9701208e2a6ab71eaee2d00b6e2bd49acbc3e561414e923952ca702d33662511fe057a95bad125609f6216b620 WHIRLPOOL ad1110b5ebcfe912f32701385c9f0af7295790803d42ed3406258e0b38eba8b36895db28cffdc6176617e4726e8d09eb98301429f54d2e9d30763bcf5fa96bf8
diff --git a/dev-haskell/monads-tf/metadata.xml b/dev-haskell/monads-tf/metadata.xml
new file mode 100644
index 000000000000..e8f31f7a0564
--- /dev/null
+++ b/dev-haskell/monads-tf/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Monad classes using type families, with instances for various
+ monad transformers, inspired by the paper /Functional Programming
+ with Overloading and Higher-Order Polymorphism/, by Mark P
+ Jones, in /Advanced School of Functional Programming/, 1995
+ (&lt;http://web.cecs.pdx.edu/~mpj/pubs/springschool.html&gt;).
+
+ This package is almost a compatible replacement for the @mtl-tf@ package.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/monads-tf/monads-tf-0.1.0.1-r1.ebuild b/dev-haskell/monads-tf/monads-tf-0.1.0.1-r1.ebuild
new file mode 100644
index 000000000000..1bd88c4f6339
--- /dev/null
+++ b/dev-haskell/monads-tf/monads-tf-0.1.0.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Monad classes, using type families"
+HOMEPAGE="http://hackage.haskell.org/package/monads-tf"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/transformers-0.2.0.0:=[profile?]
+ <dev-haskell/transformers-0.4:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2.3"
diff --git a/dev-haskell/monads-tf/monads-tf-0.1.0.1.ebuild b/dev-haskell/monads-tf/monads-tf-0.1.0.1.ebuild
new file mode 100644
index 000000000000..1bd88c4f6339
--- /dev/null
+++ b/dev-haskell/monads-tf/monads-tf-0.1.0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Monad classes, using type families"
+HOMEPAGE="http://hackage.haskell.org/package/monads-tf"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/transformers-0.2.0.0:=[profile?]
+ <dev-haskell/transformers-0.4:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2.3"
diff --git a/dev-haskell/monads-tf/monads-tf-0.1.0.2.ebuild b/dev-haskell/monads-tf/monads-tf-0.1.0.2.ebuild
new file mode 100644
index 000000000000..d6464af687eb
--- /dev/null
+++ b/dev-haskell/monads-tf/monads-tf-0.1.0.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Monad classes, using type families"
+HOMEPAGE="http://hackage.haskell.org/package/monads-tf"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/transformers-0.2.0.0:=[profile?] <dev-haskell/transformers-0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2.3
+"