summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/mustache/mustache-2.3.1.ebuild')
-rw-r--r--dev-haskell/mustache/mustache-2.3.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-haskell/mustache/mustache-2.3.1.ebuild b/dev-haskell/mustache/mustache-2.3.1.ebuild
new file mode 100644
index 000000000000..23b768a9e9d5
--- /dev/null
+++ b/dev-haskell/mustache/mustache-2.3.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.2
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A mustache template parser library"
+HOMEPAGE="https://github.com/JustusAdam/mustache"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # tries to access network
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ dev-haskell/cmdargs:=[profile?]
+ dev-haskell/either:=[profile?]
+ >=dev-haskell/mtl-2.2.1:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/scientific:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/th-lift:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ dev-haskell/vector:=[profile?]
+ dev-haskell/yaml:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( dev-haskell/base-unicode-symbols
+ dev-haskell/hspec
+ dev-haskell/lens
+ dev-haskell/tar
+ dev-haskell/temporary
+ dev-haskell/wreq
+ dev-haskell/zlib )
+"