summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/quickcheck/quickcheck-2.8.1.ebuild')
-rw-r--r--dev-haskell/quickcheck/quickcheck-2.8.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-haskell/quickcheck/quickcheck-2.8.1.ebuild b/dev-haskell/quickcheck/quickcheck-2.8.1.ebuild
new file mode 100644
index 000000000000..6a77b868ca7c
--- /dev/null
+++ b/dev-haskell/quickcheck/quickcheck-2.8.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+#hackport: flags: +base4,-base3,templatehaskell:template_haskell
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+MY_PN="QuickCheck"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Automatic testing of Haskell programs"
+HOMEPAGE="https://github.com/nick8325/quickcheck"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux"
+IUSE="+template_haskell"
+
+RDEPEND="dev-haskell/random:=[profile?]
+ >=dev-haskell/tf-random-0.4:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/test-framework-0.4 <dev-haskell/test-framework-0.9 )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-base3 \
+ --flag=base4 \
+ $(cabal_flag template_haskell templatehaskell)
+}